blosxom :: the zen of blogging


  • home/about
  • features
  • colophon
  • news
  • mailing list

  • documentation for users

  • overview
  • install
  • configure
  • blog
  • view
  • flavour
  • syndicate
  • plugins
  • plugin registry
  • static
  • faq
  • use cases*
  • documentation for developers

  • overview
  • plugins
  • downloads

  • mac
  • windows*
  • everyone

  • license
  • contributed*
  • powered by

    Install Blosxom

    Blosxom is designed to run just about anywhere, requiring only a fairly recent vintage operating system (Mac OS X, Windows 2000/XP, Unix/Linux), a Web Server (Apache, IIS) to serve up your blog's Web pages, and the Perl programming language (Perl 4 or 5, preferably the latter) to run the Blosxom CGI script.

    The installation process is designed to be as easy as possible, requiring very little from you in terms of knowledge of programming or additional bits and bobs to install.

    Chances are you fall into one of the following four camps:

    • Blosxom at your ISP
      You've an account at your local Internet service provider (ISP) which allows you to have my own Web site and run your own CGI scripts.

      click here to begin...

    • Blosxom on your Mac
      You'd like to run Blosxom right on your Mac OS X laptop or on an old desktop humming away in your closet, serving up your Web site and much in need of a blog.

      click here to begin...

    • Blosxom on your Windows box
      You'd like to run Blosxom under Windows 2000 or XP Professional using the built-in Internet Information Server (IIS) to serve up the site.

      click here to begin...

    • Blosxom for Unix/Linux
      You'd like to run Blosxom on your Unix/Linux box. Assuming you--being a Unix/Linux user--are somewhat more familiar with installing, configuring, and running Perl CGI scripts, extrapolating from the "Blosxom at my ISP" instructions should serve you well.

      click here to begin... Logo